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Introducing JMP 7 
By John Sall, SAS Institute 

JMP 7: Talking to the Next Level 
When we hear from researchers with 16 gig of 
memory in their computer, who want to read 
tables with 500,000 columns, and want to put to 
work all 8 cpu cores of their machine, we aren’t 
just doing small jobs anymore. JMP needed to 
grow up in many ways to handle these kinds of 
jobs. JMP had to learn new tricks, too, and using 
advances in algorithms as well as computing 
power has made huge differences. 

 Imagine doing a hierarchical cluster analysis on 30,000 rows in a few seconds, 
or estimating defect rates of  one in a million in simulations so fast that it re-
simulates and shows results as you move the mouse. Imagine getting true  
p-values from saturated screening models. Imagine getting optimal 
experimental designs for split-split plot designs. All these new tricks would 
seem difficult to impossible until now, but are easy in JMP 7.  

A Summary of New Features in JMP 7 
For business applications: 
• Extensive SAS Interface that makes JMP an intelligent SAS client 
• More visualization features, with 3D and dynamic bubble plots 
• Handling larger problems with multithreading and better algorithms 
• Dynamic data filtering 
• Survey analysis, including multiple response models 
• Better presentation-quality graphics with more customization 
• Ability to save projects that embed many datasets in one file 
• Smart color-coded script editor 

For engineering and science: 
• Enriched capability analysis, including goal plots that show hundreds of 

the process capability variables in one plot.  
• Computer experiments, more space filling designs, Gaussian Process fits 
• Improved Simulation that can use filtered Monte Carlo methods 
• Defect profiling, tolerance design, and robust process engineering 
• Model selection for screening designs 
• Improved estimates of variance models 
• Multivariate control chart 
• Time series transfer functions 
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Better Visualizations 

Dynamic Visualization With Bubble Plots 
Graphs are usually thought of as static entities, even if 
they have drill-down and customization features. A 
graph isn’t usually an action story where you see 
things happen across time. But, if graphs could be put 
into motion, you would have a more powerfully 
immersive, compelling, and engaging experience. You 
would also have more sensitivity to the data. Motion-
sensitive vision is a powerful survival skill that has 
evolved in humans; we are here today because our 
motion-sensitive vision has served us for spotting prey 
and predators. 

The pioneer of dynamic plots, Hans Rosling, has 
videos of flash-enabled world demographics 
presentations on his web site 

http://www.ted.com 

The motion-enabled graph in JMP 7 is the Bubble 
Plot. The idea is to harness and show more dimensions 
of data. A bubble plot is an entity that works in up to 
six dimensions: 

• X axis • Y axis 

• size of bubble • color of bubble 

• time variable • aggregation variable 

When there is a time variable, you can play the graph 
in continuous time, with the positions, colors, and 
sizes interpolated across the time data points into 
smooth motion. All these dimensions let you watch a 
story unfold. The story replays so you can absorb 
more detail. You see the movers and the shakers among 
the points. You see which points are leaders, which are 
followers, and which are contrarians. You aggregate 
groups and disaggregate a group to see if it really does 
behave as a group or if it actually behaves as an 
individual. 

The data tables for the following examples (shown in 
Figures 1-4) are available with this JMPer Cable on the 
JMP web site at 

www.jmp.com/about/newsletters/jmpercable/ 

Scripts are included with the data tables that run the 
examples. Scripts for the pollution example include 
coordinates for the United States and selected cities. 

Property and Violent Crime Rates 
A bubble plot of crime statistics across regions of the 
United States for the last 30 years shows any regions 
that had major changes over time. Figure 1 shows the 
bubble plots for 1975 and 1998. The south appears 
to have had an increase in violent crimes. But, 
highlight the south region bubble and use the Split 
command to see how the crimes rates appear within 
each state within the region. This example uses the 
CrimeData.jmp data table. 

SAT Scores 
Figure 2 shows SAT Math and Verbal test scores in 
1992 by state, sized by percent of population taking 
the test. Iowa appears to have done the best, but few 
students there took the test. Hawaii and California did 
much better on math than verbal, which might 
indicate that a large proportion of the population has 
English as a second language. This example uses the 
SATbyYear.jmp data table. You can open this table, 
run one of the scripts saved with the table and click on 
Go to see these bubbles move as the bubble plot cycles 
through twenty years of data. 

Pollution in the United States  
Figure 3 shows average maximum temperature in 
January for a number of US Cities. This example does 
not have a time variable (is not motion enabled), and 
simply displays selected cities with bubbles sized by 
population. This example uses the PollutantsMap.jmp 
data table. 

The Baby Boom 
The bubble plot is a perfect tool to look at age group 
distributions in countries of the world and see how they 
changed in the last 40 years. You can see how the baby 
boom happened in many countries, then aged through 
the groups, and how some countries still have young-
dominated populations. Figure 4 shows the change in 
age distribution over time (first and last frames) for 
selected countries. The bubble plot moves over the span 
of years to create a dynamic view of the population age 
distribution as it changes. This example uses the 
PopAgeGroupSubset.jmp data table. 

There are many examples of business and scientific 
data that are already in time series, and dynamic 
motion-enabled bubble plots can tell their stories. 
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Figure  1 Proportion of Violent Crime Rate by Proportion of Property Crime Rate, Sized and Shaded by Region, for 
Years 1975 and 1998: South Delineated by State Shows the Effect of Florida 

 
 

Figure 2  SAT Verbal and Math Scores for States in 
1992  Sized by Proportion of Population 

  

Figure 3 Bubble Shading Indicates Maximum January 
Temperature  and Size of Bubble shows City Population 

 

 

 

Figure 4  Age Distribution by Country for 1970 and 1993  
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Immersive Visualization – Scatterplot 3D 
Harnessing the 3rd dimension has been a long-
established goal of JMP. Version 1 of JMP introduced 
the spinning plot, and Version 4 introduced the surface 
plot. JMP 7 builds on that progress with a new 
platform called Scatterplot 3D and a number of 3D 
plots inside of statistical platforms. 

First, our priority was to bring a faithful and 
cusomizable environment to show points in space. We 
developed the axes, walls, lights, and controls to make 
this world. You can click to identify points, drag axes, 
and drag to spin the whole plot. When a wall moves in 
front of the point space, it disappears and another wall 
appears behind the points. 

Scatterplot 3D, as the replacement for spinning plot, 
needed to support the principal components and biplot 
rays. Suppose that you have six or eight dimensions, 
but the data is correlated across those dimensions. This 
means that if you rotate the data (in six dimensions) 
and orient those rotations to align the most variation in 
the data in the first three dimensions, then you capture 
most of the variation of the data in a graph that you can 
now see in a spinning three-dimensional plot. If you 
add arrows (rays) showing the directions of the original 
variables in that space, what you get is called a 3D 
biplot. Figure 5 shows a biplot as it is displayed by the 
Scatterplot 3D platform. 

If your data is grouped, and has a somewhat 
multivariate normally shaped distribution, then you 
can capture the essence of the data by adding normal 

Figure 5  Biplot in the Scatterplot 3D Platform 

 

contour ellipsoids in the space, with each one 
describing a percentage of the distribution captured by 
each group. Figure 6 shows normal contour ellipsoids 
imposed on Fisher’s Iris data (Iris.jmp in the sample 
data folder). 

If your data has a more irregularly shaped distribution, 
and you want to see that distribution to gain a better 
picture than you would get with a point cloud, then a 
3D kernel density estimate with semi-transparent 
contours will be valuable. Use the Cytometry.jmp 
sample data table to create the contours in Figure 7.  

Figure 6 Scatterplot 3D with Normal Contour Ellipsoids Figure 7 Scatterplot 3D with Kernel Density Estimates 
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Software from SAS and JMP Join Forces and Work Together 

 

JMP began in 1989 trying to be as different from SAS 
as a spreadsheet is from a database. JMP was for 
scientists and engineers, SAS was for business analysts, 
IT specialists, and statisticians. JMP was point-and-click 
easy to use. SAS was programmable and powerful. But 
over the years, this distinction made less sense. JMP and 
SAS are grounded in the same talents, produced by the 
same company, and have the same overall analytics 
theme: The Power to Know. 

Although SAS has complete and comprehensive statistics 
and data management abilities, JMP augments the SAS 
offerings. Think of JMP as a SAS client (like SAS 
Enterprise Guide) that specializes in bringing your data 
to you in a way that lets you slice and spin, and make it 
come alive. SAS Enterprise Guide is a powerful client to 
SAS that provides a complete set of dialogs for creating 
SAS code to run SAS procedures, allowing you to author 
stored processes and generate code. JMP is great at 
letting you play with your data and see key things. 

JMP has an attitude toward data that is close, personal, 
and allows direct data manipulation. JMP has the feel of 
a spreadsheet, but with the supportive structure of a 
database and much more graphical responsiveness. 
Everything in JMP is active on the user interface surface; 
changes happen instantly, eliminating the usual step of 
sending a job to the server and retrieving the results 

 

While JMP is great by itself for isolated projects, it 
needs the server applications to knit together systems of 
data and applications. JMP 7 interfaces with SAS in 
many ways: to data, to metadata, to stored processes, to 
server pools. 

If your data or metadata is in SAS, JMP can access it. 
You can develop SAS jobs in the JMP graphical 
environment, submit them from JMP, and get back 
the results in JMP. You can open SAS data sets and 
dynamically analyze them in JMP. You can browse 
metadata libraries for data and stored processes. In a 
couple of cases (including Fit Model), JMP will even 
generate SAS code so you can compare SAS and JMP 
results for the same analysis. This is important in a 
regulated environment when validation is required. 

Now the products are joined. JMP users get the power 
of SAS. SAS users get the visualization front end of 
JMP. JMP readily connects to SAS Workspace servers 
and to the SAS Metadata server. JMP can access and 
run stored processes, can browse SAS data, and 
Business Intelligence users can take advantage of the 
power of dynamic visualization of their data through 
JMP. Figure 8 shows an example of the interface 
between JMP and SAS. 

Figure 8  Example Windows Showing JMP and SAS Integration 
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Dynamic Data Filter 
JMP Users treasure the ability to select rows with simple 
mouse clicks, select groups by clicking histogram bars, or 
select ranges by dragging a selection rectangle across a 
scatterplot. This gave us the idea for the new Data Filter 
command, found in the Rows menu. With JMP 7’s 
data filter, selection just got more convenient and more 
powerful. 

• Convenience comes with access from a compact side 
panel on the data filter interface. 

• Power comes with one-click access, not just for 
selection, but also for hiding and excluding—or the 
reverse, showing an including.  

The Data Filter panel lets you select groups defined by 
many variables. In addition to selecting rows, you can 
also hide/unhide, and exclude/include them. On the 
Data Filter panel, you click on values of categorical 
variables to select them. Clicking on a slider panel selects 
intervals of continuous variables (See Figure 9). 

Click on a group when the Include mode box is 
checked, and graphs and analyses focus on that group 
instantly. This one click is equivalent to 

1) Select 

2) Invert Selection 

3) Exclude 

4) Deselect, then 

5) Rerun 

Let’s take a look at Car Poll.jmp from the sample data 
folder, which records the country-brand preference of 
cars in a group of car owners, identified by age, sex, 
marital status, and other variables. 

Suppose you want to see the country distribution for 
married males between the ages of 18 and 40. You could 
use multiple histograms and carefully highlight the 
appropriate bars, but the new Data Filter compactly 
represents the values in many columns, both categorical 
and continuous.  

Figure 9 shows this complex subset as defined by the 
Data Filter. The menu on the Data Filter title bar has a 
Make Subset command. Also, there is a Save Where 
Clause command that can save a script command 
defining that subset. Note that the Distribution report is 
for all 303 observations in the data table, but only 97 
are selected.  

Figure 9  Identify a Complex Subset with the Data Filter 

 
Using the Data Filter for Animation 
Using histograms, you can see how groups are arranged 
in plots by clicking on histogram bars and watching 
how the points highlight. The animation feature in the 
Data Filter causes sequential highlighting of the values 
of a single variable, showing how results change in 
plots, charts, and in the data table. Individual values 
can always be highlighted in the data table. However, 
patterns are more interesting if you first create a plot 
and then invoke the animation of a variable using the 
Data Filter to see how it behaves on the plot. 

To use the animation feature, 
first click on one of the variables 
on the Data Filter control panel 
to select it (see Marital Status in 
Figure 9). Then choose 
Animation from the Data Filter 
menu to display the Animation 
control panel, as shown here. Use 
the control panel to start and stop the animation, and 
control animation speed and direction. The animation 
cycles through values of either character or numeric 
variables.  

Automatic Recalculation 
Instant updating, done for Include/Exclude by the data 
filter, is also done for the simpler statistics and graphics 
platforms but not for the more complex modeling 
platforms that can take more time to update. On the 
Distribution platform, the title bar menu now has a new 
command, Automatic Recalc. When this command is 
in effect, the Distribution reports automatically 
recalculate whenever you exclude rows or change values 
in the data table. Automatic recalculation will be 
expanded in future releases of JMP.  
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Power Features and the JMP 7 Interface 
Richard Potter, SAS Institute 

JMP Projects: A Better Way to 
Organize Your Work 
A new feature for JMP on Windows is the ability to 
save a complete project that can include data tables, 
journals, scripts, and many other kinds of files. By 
saving files in a JMP project you can easily share all 
of these files with a coworker. Before the project 
manager in JMP 7, it was time-consuming to find 
all these files and collect them together. If you link 
to the files from a journal, your link paths in the 
journal can easily break, even though you could edit 
them to use relative paths. 

In a JMP 7 project, drag or open files, folders, mail 
from Outlook, URL links, windows, and other 
elements to the project window, then save the 
project. The project is saved as a compressed file. 
You have the option of saving the project with links 
to all of its elements, or having the project save its 
own copies of all the project elements. When a 
colleague opens the project, it places all the files into 
a single folder, and preserves all saved paths. Also, 
you can document your project with the Edit Notes 
command from the Project menu. 

To create a JMP project, choose File > New > 
Project or View > Projects. The Project window 
then appears on the left side of the JMP application 
window. The project window can be moved 
(undocked) from the JMP application window. To 
access elements for the project, use View > Window 
List and View > File System to open these lists, 
which can also be either docked or undocked from 
the JMP application window. Then just drag or 
open the items you want from these windows. 

Figure 1 shows an example of a Projects window. 
The project name is Newsletter. It has two groups 
named Review and Production. The Review 
group has word processing documents, JMP data 
tables, a JMP script, the results of a bivariate 
analysis, and a PowerPoint® presentation. The 
Production group has the final newsletter 
document, a folder containing a set of pictures for 
the document, a graphic of a logo, and an Excel® 
spreadsheet containing the mailing list for the 
newsletter. This example newsletter project contains 
all the relevant pieces needed for all parties involved 
in a document creation process. 

Figure 1  Projects Window and Commands 

 

The project is saved with .JMPPRJ appended to its name. 
Although you can only create a JMP 
project on Windows, you can open a 
project with JMP on the Windows, 
Macintosh, and Linux operating systems.  

Notice the list of project commands shown on the right 
in Figure 1. In addition to commands that add elements 
to a project, there are commands that determine how a 
project is to be saved and reopened. To open a project on 
the Mac or a Linux machine you must save the project 
with all its files, and specify that the files be opened when 
the project is again opened using these commands: 

• When Restore all windows when project is 
opened is checked, all files open automatically when 
you again open the project. 

• When Archive all files and folders when project is 
saved is checked, copies of the project elements are 
saved with the project instead of just links to the 
elements. 

The File System Toolbar 
Another new feature for Windows users in JMP 7 is the 
File System toolbar. This toolbar appears when you select 
the File System command 
from the View menu. 
Although this toolbar initially 
appears docked on the left-
hand side of the main JMP 
window, it can be undocked so 
that it floats by clicking in its 
title area and dragging it away 
from the main window frame. 
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File System Toolbar (continued) 
The File System toolbar shows the directories and 
files on your computer in a tree structure. You can 
use this toolbar to navigate into any directory or file 
on your computer. Once you’ve located a file, you 
can open it by double-clicking on the icon for that 
document.  

Figure 2 shows navigating to a directory that has 
some sample data files and selecting an Excel file 
called Europe.xls. If you click on the icon in the 
tree, this spreadsheet opens as a JMP table. To open 
the file in Excel instead, right-mouse click on the 
icon and select the Open outside JMP command 
from the popup menu.  

The options in the popup menu vary depending on 
the type of file selected. If the file you select is a JMP 
table or script, then you have the option to open the 
file within JMP or open and run the script. 

Figure 2 File System Toolbar File Options 

 

By default, the File System toolbar lists the files on 
your hard drive. However, you can add other 
network servers to the tree. Click on the red triangle 
at the top of the File System toolbar and select Add 
Folder from the popup menu. Then use the 
Browse for Folder dialog that appears to navigate 
to any server on your network. When you locate the 
volume you want, select it to see a new folder node 
inserted at the top of your tree hierarchy. 

You can now expand that folder and navigate to any 
directory or file of interest. JMP will remember that 
you added that folder to your File System toolbar—
whenever you launch JMP and display the File 
System toolbar, the new node is shown. If you 
decide you don't want that node in your File System 
view, right-click on it and select the Remove 
Folder command. This only removes the node for 
that folder from the tree presented by the File 
System toolbar—the directory itself as it exists is not 
affected. 

Menu Customization 
The menu customization implementation in previous 
versions of JMP had various shortcomings, which our 
users pointed out to us. In response to their feedback, we 
have made dramatic changes to menu customization in 
JMP 7.  

First, JMP 7 allows you to merge customizations you 
made to your menus and toolbars in JMP 6. When you 
first launch JMP 7, it automatically prompts you to 
merge your customizations from JMP 6 (if there were 
any). This new merge process inserts into JMP 7’s main 
menu and toolbars whatever commands, menus, and/or 
toolbars were unique to your customization of JMP 6. 
This is a huge improvement over previous versions of 
JMP, which did not support any kind of merge feature. 

In previous versions of JMP, menu customization was an 
all-or-nothing affair. If you wanted to add a single new 
command, you had to add the command in the menu 
editor and then save it to a special JMPCMD file. That file 
contained the definition of your entire main menu; 
hence, if you gave that JMPCMD file to someone else and 
they applied it to their JMP session, it replaced their 
entire main menu. 

Now, with JMP 7 you can define a single menu, toolbar, 
or command, which you can export to a file with the new 
.JMPMENU file extension. If someone else imports your 
JMPMENU file, your new command is added to their 
menus. When you export your menu definition, you can 
even specify whether or not JMP should preserve its 
context so that whenever someone else imports your 
JMPMENU file, your command will be inserted into their 
main menu in the same location as it is in your main 
menu. 

Perhaps the biggest drawback to the old menu 
customization scheme was that your menu definitions and 
any JSL scripts upon which they depended were 
disconnected. This made it difficult to share your menu 
customizations with others. For example, suppose you 
were using JMP 6 and 
you added a new menu 
to the main menu called 
NTheory which 
contained two JLS script-based commands called Euler 
Phi and Fibonacci. Thus, the path to the script to be 
executed was coded into the definition of the command. If 
you wanted to share your new menu, it wasn’t sufficient to 
provide only your JMPCMD file—you also had to supply 
the associated JSL files. 
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Menu Customization (continued) 
Further, even if you supplied both the JMPCMD file 
and the script files, it was still unlikely that the new 
menu would function because the paths to copies of 
the JSL files would probably not match. 

JMP 7 eliminates all these problems with the new 
JMPMENU file. When you export your customized 
menu, you are prompted whether you want JMP to 
save the JSL files that your menu commands use. If 
so, then these associated JSL scripts are saved into the 
JMPMENU file along with the new menu definition. 
When the JMPMENU file is imported, JMP extracts 
the JSL scripts, saves them into a special 
Dependencies directory, and changes the 
commands to point to those JSL files. After importing 
your JMPMENU file, everything needed for the 
customization is contained in just one file. 

The JMPMENU file is really a Zip file. Therefore, if 
you're curious about what's inside your menu file, 
you can always examine it outside of JMP by using a 
tool such as WinZip. By default, if you are running 
the Windows operating system in an English locale, 
your JMPMENU files are stored in  

C:\Documents and Settings\user-name\Local 
Settings\Application Data\JMP7 Data\English 

Lastly, JMP 7 automatically imports menu 
customizations if you put your jmpmenu file in a 
special folder of your installation directory. For 
example, if you’re running under Windows with your 
locale set to English and you’ve installed JMP in the 
default location, then the following path takes you to 
the English support files that JMP depends upon: 

C:\Program Files\SAS\JMP7\Support Files English 

All you have to do is create a folder called Factory 
Default Menus and copy your JMPMENU files into 
that location. You are allowed to have as many such 
files as you like in that folder. Then, whenever JMP 
launches, it automatically imports each JMPMENU file 
in the Factory Default Menus folder into the main 
menu and toolbar list.  

If any of the commands in your customized menus 
use JSL scripts, make sure they were saved when you 
exported your menus. When JMP imports the menu, 
it extracts the JSL files and places them in a 
Dependencies directory within the Factory 
Default Menus folder. 

 

The Menu Editor: An example 
The menu editor has a new 
interface in the Windows 
version of JMP 7. To 
access the menu editor, 
select Edit > Customize > 
Menus and Toolbars, as 
shown here. This 
command docks the 
Menus window on the left-
hand side of the main window.  

JMP 7 combines the ability to edit your main menu 
and toolbars in one window. This facilitates copying 
and/or moving commands between menus and 
toolbars. Previously, the menu editor was in a separate 
window from the toolbar editor.  
Main menu and toolbars are represented using tree 
structures. The root of your main menu is the Main 
Menu node and the root of the list of toolbars is the 
Toolbars node. If you click on the plus (+) symbol 
next to Main Menu, the node expands and lists all its 
menus. Likewise, if you click on Toolbars, the list of 
all your toolbars appears. Click the minus (–) next to 
the node name to collapse its list. 

Suppose you want to add a new menu called NTheory 
(shown previously) to the main menu, positioned 
between the Graph and the Tools menus. The 
NTheory menu has two commands: Euler Phi and 
Fibonacci. 
1) Select Edit > Customize > Menus and Toolbars 

to see the Menus window (see Figure 3). 

2) Click the + sign to the left of Main Menu (in the 
Menus window) to expand it (see Figure 3). 

3) Right-click the Graph menu item. 

4) Select Insert After from the menu that appears. A 
new Untitled item now shows beneath the Graph 
main menu item.  

5) Double-click on the new Untitled item to see the 
Menu Item Properties dialog. 

6) Type the new menu name (NTheory) into the 
Caption box. 

7) For Menu Item Type, click the Submenu radio 
button and then click OK.  

8) Now, right-click NTheory and select Insert into 
Submenu from the menu that appears. This  
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Menu Customization (continued) 
creates an Untitled submenu item for NTheory. 

9) Double-click the Untitled submenu item and use 
its Menu Item Properties dialog.  

10) Name the item Euler Phi and complete the dialog 
to describe the properties for this command. 

11) Right-click Euler Phi and select Insert After to 
add the second Untitled submenu command. 

12) Again, double click Untitled and complete the 
Menu Item Properties dialog; name the command 
Fibonacci and give it the other properties you 
want. 

13) Click Apply. 

You are finished modifying the main menu. 

Important: In order for any modifications to take effect, 
you must click the Apply button in the top right-hand 
corner of the Menus window (See Figure 3). 

In general, to add a submenu to any command, new or 
existing, the steps are exactly the same. First, you create 
a new item and set its type to be submenu in the 
Menu Item Properties dialog. Then, right-click and 
select the Insert into Submenu command. This adds 
a new item into the submenu itself. Continue and 
complete rest of your submenu using the Insert 
Before and Insert After commands as usual. 

Figure 3  The Menu Window With New Items 

 

 

 

What’s New in DOE 
Bradley Jones, SAS institute 

JMP 7 has made major improvements to existing 
platforms and added new functionality, such as 
optimal design for 

• random block designs 
• split-split-plot designs 
• strip-plot designs 

There are now optimal designs for generalized linear 
models, including models with 0-1 responses or 
response that are counts such as 

• binomial regression 
• poisson regression 

Optimal nonlinear regression is improved. It is faster, 
more efficient, and more robust to parameter mis-
specification. 

JMP 7 introduces new designs and also a new fitting 
method that specifically addresses the unique behavior 
of computer simulation models. There are two new 
space-filling designs: 

• Maximum entropy, which measures the amount 
of information contained in the distribution of a 
set of data 

• Gaussian process IMSE optimal, which creates a 
design that minimizes the integrated mean 
squared error of the Gaussian process over the 
experimental region 

The new Gaussian Process platform (Analyze > 
Modeling > Gaussian Process) deals with no-error-
term models, such as those found in computer 
simulation experiments, which often perfectly 
interpolates the data. The Gaussian Process platform 
fits a spatial correlation model to the data, where the 
correlation of the response between two observations 
decreases as the values of the independent variables 
become more distant. 

The design of computer simulation experiments is one 
of the most important additions to JMP Design of 
Experiments. 

Why Computer Experiments? 
In an effort to speed the development of new products 
and processes, many companies are turning to 
computer simulations to avoid the expense and lost 
time of building prototypes. However, these computer 
simulations are often very complex and it may take  

You must click Apply 
for menu changes to 
take effect. 

Double click on item to 
see the Menu Item 
Properties dialog. 

Right-click on item to see 
popup  commands. 
shown below. 
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What’s New in DOE  (continued) 

hours to complete a single run. If there are many 
variables affecting the results of the simulation, then it 
makes sense to design an experiment that gains the 
most information possible from a limited number of 
computer simulation runs. 

The absence of noise is the key difference between 
computer simulation experiments and experiments in 
the real world. Since there is no variability in the 
results of computer experiments, optimal designs 
based on reducing variance have questionable utility. 
Replication, which is usually a good thing, is 
undesirable in computer experiments. Thus, a new 
approach to experimentation is necessary.  

Because there are often many variables, and a single 
computer run might be lengthy, you want a surrogate 
model for the simulation. This model must be an 
adequate approximation to the computer simulation, 
and give fast predictions for new points. Gaussian 
Process (GASP) models are standard when designing 
a surrogate model because they are flexible and 
parsimonious in the number of unknowns. Further, 
the GASP model can interpolate data, which is 
necessary because there is no error for x when you 
have observed data.  

Example: Heat Exchanger Study 
An example given by Qian, et al. (2006) involved 
finding optimal settings of four characteristics of a heat 
exchanger, where maximizing heat transfer was critical. 
The unit was composed of many thousands of 
conduction areas, and evaluating the design space 
would require computationally extensive simulations. 

However, preliminary work provided upper and lower 
bounds for four of the heat exchanger factors (design 
variables discussed in reference): 
 m input Temp k Wall Temp 
Lower bound 0.00055 270.00 202.4 330 
Upper bound 0.001 303.15 360.0 400 

Using these variables with estimated bounds allowed 
JMP to create a space filling design; Responses, based 
on previous studies, give estimated heat transfer for the 
design points (Figure 1). 

Figure 1  Heat Transfer Design Table with Response Data 

 
Gaussian Process( 
 Y( :heat transfer ), 
 X( :m, :Input Temp, :k, :Wall Temp ) 
) 

Space Filling designs automatically save a Gaussian 
Process analysis script with the design table. Figure 2 
shows the results of the analysis for the data in Figure 
1.  

The Gaussian Process analysis report first shows an 
Actual by Predicted Plot, where the predicted values 
are jackknifed; that is, the predicted values at each 
point are computed excluding the observed value at 
that point. A model report and plots (not shown) are 
based on function-driven variance computations. JMP 
uses the product exponential correlation function with 
a power of 2 as the estimated model. 

The Prediction Profiler is available from the menu on 
the Gaussian Process title bar, and its Maximum 
Desirability command finds the optimal settings for 
the factors, as shown on the right in Figure 2. 
Reference: Z. Qian, C. Seepersad, R. Joseph, J. Allen and C. F. J. 

Wu (2006). Building surrogate models with detailed 
approximate simulations. ASME Journal of Mechanical 
Design, 128 , 668-677. 

Figure 2  Results of Gaussian Process Analysis, with Maximum Desirability to Identify Factor Settings   
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