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The name JMP was chosen partly to convey
the idea of a lively product that jumped
responsively to the user’s wishes. This
article examines why the fine-grained
progressive nature of JMP’s interactivity
makes it feel more lively than other
statistical products.

The reason that other software products
don’t feel as lively as JMP is that they really
aren’t interactive. They give the illusion of
being interactive by having dialogs that you
fill out interactively, and output that you can
view and customize interactively. But the
statistical heart of the analysis lives only a
brief life and is not interactive at all. Under
the skin of these products is an old patched-
up batch program that has been front-
ended with a mask of dialogs and back-
ended with a word processor or a graphics
editor. The dialogs are nice in many ways.
They eliminate much of the learning and
remembering burden of a command
language system. So what’s wrong?

The key fault of these packages is that they
force you to front-load all decisions before
you see any results. You fill out pages of

Comment from an anonymous
graduate statistics student:

“I took a statistics class as an under
graduate, but I never really put the
regression tools in my head—they fell
out after the final exam. I think with
JMP I’ll be able to take it with me this

time.”

dialog that offer you dozens of features,
diagnostics, reports, and graphs, and you
have to decide right then what you will want.
Do you want a plot of the residuals? You’d
better say yes now because if you say no and
change your mind, you will have to go back
and rerun the whole analysis.

The problem with front-loading decisions is
that the decisions have nothing to do with
the results. There is no interactivity. There
are no feedback cycles. Instead of exploring
the data firsthand, you are an absentee
bureaucrat handing it a book of filled-out
forms. That may work fine when the goal is
only to do a prescribed analysis. But it makes
it harder to explore, and it makes it less likely
that you will discover interesting and
valuable phenomena. You spend more time
filling out forms, and less time looking at the
results. The dialogs demand your attention
on their schedule, rather than provide
interactive features that are at your service
when you want them.

The lack of interactivity leads to a number of
other problems in the design of statistical
products. There are more analyses and each
analysis is more specialized. For example,
Instead of presenting a unified interactive
platform for exploring a distribution, there
are separate commands for descriptive
statistics, histograms, box plots, and
distributional tests. This gives more
interactivity in a sense because you have to
interact with the product each time to ask
for each element, and you see results before
doing the next step. But this interactivity is a
burden, not a boon. You are throwing away
the context of the analysis you have
established. You have to go back to the

top of the command tree, find the new
command, and go through its dialogs,
selecting again the variable of interest. The
results come out in a separate window, and
you end up having to examine and close many
windows instead of one.

Then the system grows to adapt to the
problems it creates. To compensate for the
burden of doing many little commands, you
are offered scripting or macros or templates
to automate them. To compensate for having
separated output, you are offered a window
in which to paste results together. To
compensate for having too many commands
offered at the top, you are offered another
system of dialogs to select the right
subcommands. �

(continued on page 2)
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THE CASE OF THE
MISSING FORMULAS

Occasionally when doing
table manipulations such
as subsetting, sorting,
splitting or stacking columns, or joining
tables you might be surprised (dismayed)
to find that the formula you worked hard
to build has disappeared. Usually this isn’t
a problem because the Tables menu
commands produce new data tables, and
formulas remain intact in the original table.
You can cut and paste to retrieve them if
necessary.

Further, the circumstances that lead to a
disappearing formula are logical. The
following list tells you when formulas are
saved or lost by Tables menu commands:

• Tables →Subset

When you subset selected columns and
include a formula column but don’t
include all its column elements, that
formula is dropped from the new table,
but the computed column values
remain.

Rationale: The formula in the subset
table would have empty elements,
which could then result in missing
column values.

• Tables →Sort

Formulas in any Sort key variables you
specify are not preserved.

Rationale: There could be a conflict
between the sorted order of a variable
and the order produced by its computed
value. This is often the case if a
computed value depends on a function
of i, the row number.

However, you do have the option on the
Sort dialog to ‘sort in place.’ That is, you
can have the sort operation replace the
original table with the sorted table. In
that case the formula is retained. But be
aware that the formula does not
automatically re-evaluate. You make the
choice to either recompute the column

with its calculator or to remove the
formula from the column through the
Column Info dialog.

• Tables →Stack Columns

If any of the columns to be stacked
contain formulas, those formulas are not
kept. Also, if a column has a formula that
has as elements any of the columns to
be stacked, its formula is not kept.

Rationale: 1) If you stack computed
columns, their formulas might not all be
the same, and there is no way to choose
which one to keep. 2) Any formula that
depends on i, the current row number,
or n, the total number of rows, could
give unexpected results and is dropped.
3) Because the columns in the stack list
will no longer have their individual
column names, any formula in other
columns that refers to them is dropped.

• Tables →Split Columns

If the column to be split has a formula,
that formula is not passed to the
resulting split columns. Also, if a column
has a formula that uses any of the
columns to be split as an element, its
formula is not kept in the new table. In
addition, any formula that depends on a
column used as a Col ID is also dropped.

Rationale: The reasons for dropping
formulas when splitting columns are the
same as those for stacking columns.
Also, if splitting columns uses an ID
column, that column does not exist in
the new table; therefore, any formula
dependent on it would have missing
elements.

• Tables →Join

If a column formula depends on another
column element that is dropped (not
kept) from the joined table, the formula
is not kept but the computed values
remain. Joining with matching variables
when both matching columns have a
formula, and keeping non matches
keeps both formulas but you have to
reevaluate the columns. Similarly, if you

join by matching columns that have
formulas and drop one of those
columns, the other retains its formula.
However, you should reevauate to be
sure the results are correct. In general,
make the choice to either recompute
the column with its calculator or to
remove the formula using the Column
Info dialog.

Rationale: Formulas that depend on
columns that are dropped in the joined
table would have empty elements,
which could then result in missing
column values.

• Tables →Transpose

…left as an exercise for the reader.

(continued from page 1)

To compensate for losing the context of
the analysis, you are offered options to
replay the forms you last submitted so that
you can change the options.

Contrast this with JMP. Analyses are
interactive and progressive. At the top,
there are only a few general platforms; the
details unfold as the context develops in
the course of an analysis. You can decide
what to do at any time, not just when you
launch the analysis. All the results appear
grouped in one window with a highly
interactive surface. And under the
interactive surface sit interactive statistical
engines that keep the context and the
internal calculations ready to do the next
subanalysis.

With many products, you feel like you are
moving from bus station to bus station,
looking up schedules, filling out ticket
purchase forms, and staying on the routes.
With JMP, you feel you are driving, and can
explore the data at will. Bon Voyage.
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MORE POWER!
by Duane Hayes
SAS Institute Inc.

Everyone wants power. Be it political,
muscular, mental or statistical power. From
Captain Kirk of the Starship Enterprise to
Mr. Felton in your company’s statistics
department—everyone wants power. With
this in mind, JMP software offers an easy way
to calculate at least one type of power…
statistical power.

Power, as I am referring to it here, is the
probability of getting a significant statistical
test result for a given alpha level (the
probability of obtaining a Type I error). To
calculate power, you need to know the alpha
level of the statistical test, an estimate of the
standard error of the test (σ), an effect size
(δ), which is the size of the difference you
want to detect, and the sample size.

To increase the power of a statistical test, you
have several options:
• increase the alpha level
• decrease the standard error of the test
• increase the effect size
• increase the sample size.

In many cases, the first three options are
neither suitable nor possible, so the only
choice is to increase the sample size. But, this
raises the question: “How many samples are
needed?”

JMP to the Rescue!

For any least squares model, the model fitting
platform (Fit Model command) in JMP gives

a power details option for the whole model
and for each of its effects. JMP calculates
initial estimates for the power parameters
and displays them in an editable dialog.
You can then enter the values (or ranges
of values), and JMP calculates power and
sample size for all combinations of these
values.

Let’s say you plan an experiment to compare
weight gain in mice using four food
additives. Suppose you want to detect a
minimum difference in weight gain of ten
grams between any two food additive
groups, with a probability of making a
Type I error of 0.05, (that is, α=0.05). From
knowledge of earlier experiments, you have
an estimate of the standard error as σ= 3
and you want the power of the test to be at
least 0.90. How many replicates are needed?

With these parameter values, you can use
JMP to do a prospective power analysis.
This kind of analysis is a way to get JMP to
estimate power for a range of sample sizes
and minimum differences (deltas) before
actually conducting an experiment.

First, create a dummy data table similar to
the one shown in Figure A. The values for
the mean weight gain are not important
because you are going to supply your own
parameter values.

Next, choose Analyze→Fit Model and
complete the Specify Model dialog that
appears. Specify, GAIN(Y) as Y and
ADDITIVE as the only effect in the model.

Figure A  WTGAIN.JMP Table

Additive Gain(Y)

A 

B 

C 

D

1

1

1 

1

Click the Defer Plots check box because
plots are of no interest here, and then click
Run Model.

When the analysis results appear, select the
pop-up menu next to the Whole Model Test
table and choose Power Details to see the
Power Details dialog shown to the left in
Figure B. Initially, it contains estimates
given by the analysis.

Click the Solve for Power check box and
enter the following values for the
parameters as shown to the right in
Figure B. Enter .05 for Alpha, 3 for Sigma,
3.5355 for Delta, and the range From 4 To

40 By 4 for Number.

When you click Done, JMP calculates power
estimates for all combination of values in
the dialog and gives the results shown in
Figure C. You can see that a total sample
size of 16 (3 replicates for each food
additive) ensures a power of 0.90.

What Is Delta?
To complete the Power Details dialog you
needed to enter a value for Delta. The key
here is to get JMP’s delta in terms of the
minimum difference between means you
want to detect. Montgomery (1984) and a

Figure B  Power Details Dialog
Power Details Dialog

Whole Model
Click and Enter 1, 2 or a sequence of values for each:

From:
To:
By

Alpha
 0.050

     •
     •

Sigma
       0
       •
       •

Delta
       0
       •
       •

Number
      4
      •
      •

Solve for Power
Solve for Least Significant Number
Solve for Least Significant Value
Adjusted Power and Confidence Interval

Calculations will be done on all combinations

Done HelpCancel

.   

Power Details Dialog

Whole Model
Click and Enter 1, 2 or a sequence of values for each:

From:
To:
By

Alpha
 0.050

     •
     •

Sigma
3

       •
       •

Delta
      3.5355
       •
       •

Number
      4

      40
      4

Solve for Power
Solve for Least Significant Number
Solve for Least Significant Value
Adjusted Power and Confidence Interval

Calculations will be done on all combinations

Done HelpCancel

.

Figure C  Power Details Analysis Results
Power Details

Test Whole Model

Power
Alpha
0.0500
0.0500
0.0500
0.0500
0.0500
0.0500
0.0500
0.0500
0.0500
0.0500

Sigma
       3
       3
       3
       3
       3
       3
       3
       3
       3
       3

Delta
  3.5355
  3.5355
  3.5355
  3.5355
  3.5355
  3.5355
  3.5355
  3.5355
  3.5355
  3.5355

Number
     4
     8

    12
    16
    20
    24
    28
    32
    36
    40

Power
     •

0.3953
0.7678
0.9317
0.9831
0.9963
0.9993
0.9999
1.0000
1.0000
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little algebra provide the answer. First note
the following terms. Let

D = the minimum difference to be
detected

a = the number of treatment levels

Calculator
Corner

by Michael Hecht
SAS Institute Inc.

n = the number of replicates

σ2 = estimated standard error.

If µ1, µ2, ..., µa are the specified treatment
means, then define

τi = (µi - mean(µ)),
where

  
mean(µ)=

Σµi
a

is the average of the individual treatment
means.

It follows
τ2n Σ i

aσ2 =
nD2

2aσ2

This leads to

D2 =2 Στi
2

JMP’s definition of Delta2 is

δ2=
Σ (µ i– mean(µ)2)

a =
Σ (τ i

2

a
)

Substituting back, it can be shown that

D2 = 2aδ2

So JMP’s δ =  D
2a

In this example the delta to enter is
10 ÷ sqrt(2*4) = 3.5355

To Summarize

Once you understand how to do a
prospective power analysis and how to enter
the effect size you want, power and sample
size determination will no longer be
confusing, and you will always be able to see
how to obtain the power you desire (at least
statistically).

Montgomery, Douglas C. (1984), Design and
Analysis of Experiments, New York: John Wiley
and Sons.

JMP Statistics and Graphics Guide, Version 3.1,
(1995), SAS Institute, Inc.

Currently, JMP has a color palette of 12
colors (excluding black), called hues. There
are 5 shades of each hue. For plots it is
sometimes useful to create a rowstate
column that assigns colors to data table rows
based on a response variable. This is easily
done with a formula that uses functions
from the Row State and Statistical

calculator functions.

Hues
To uniformly assign one of 12 hues to a
range of numbers (call it Y), you first use the
quantile function to scale and divide Y into
12 equal intervals.

To find the intervals of Y, first subtract the
minimum, quantile Y0 , from each response
Y. Then divide that difference by the range
of the response, quantile Y1 – quantile Y0

(quantile Y1 is the maximum of Y). So the
formula is:

–Y quantile Y0

quantile Y1 –quantile Y0

You then use the Hue function to assign
colors. However, the Hue function interprets
numbers from 1 to 12 (not fractions from 0
to 1). To modify the interval values for the
hue function, multiply them by 12. The
complete formula for assigning 12 unique
colors becomes:

Y– quantile Y0

Y –quantile1 quantile Y0

hue ( •12)

To try this yourself, create a new column. On
the New Column dialog select Row State as
its data type and Formula as its Data Source.
Then enter the formula above into its
calculator. Use any response you want as Y.

Shades
The Shade function interprets numbers

from –2 to 2, giving 5 shades. You use a
formula similar to the one shown for the Hue

function to assign one of 5 shades.

Because the internal values that define shades
range from -2 to 2, (instead of 1 to 5), you
have to subtract 2 from the shade formula:

shade ( –Y quantile Y0

1 0quantileY –quantile Y
• 5–2)

Shortcut: To automatically generate these
Hue and Shade formulas, select your Y
variable and then OPTION-click (Mac) or
CNTL-click (Windows) on Hue or Shade

Hues and Shades Together
To assign both hue and shade requires
extending the formula to include both the Hue

and the Shade functions. To do this, you
create a row state column as before and use its
calculator.

Select Combination from the list of Row State

functions as shown in Figure A.

Figure A  Calculator Row State Functions
Conditions
Random
Probability
Statistical
Dates
Row State
Parameters
Variables
Editing

Combination
This row
Hue
Shade
Color
Marker
Exclude
Label
Hide

The Combination function sets up an empty 
function like the one shown
shown to the right. You fill in

, « »

the two arguments with the Hue and Shade

formulas shown previously, giving the combina-
tion of row state functions shown in Figure B.

Note: Use the calculator’s insert button to
add arguments to the Combination function
for applying more than two row states (Hide,
Label, Marker or Select).

Figure B  Combination Function Showing Hue and Shade

, « »Y– quantile Y0

Y –quantile1 quantile Y0
hue ( •12) shade ( –Y quantile Y0

1 0quantile Y –quantile Y
• 5–2)
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DOSE-RESPONSE CURVES
AND INVERSE PREDICTION
by Annie Dudley
SAS Institute Inc.

In drug studies, logistic models and curves
are often used to predict the rate of
response for different doses of a particular
drug. The logistic cumulative distribution
function lends itself well to these types of
studies because it is S-shaped and gradually
tapers off toward the extremes, while having
a steep change in the center.

To estimate the dose (or regressor, X) at a
particular probability (p) of an event, choose
a value for p and solve the equation

 
X=

ln(
p

1–p )–b 0

b 1
where b0 and b1 are parameter estimates.
The dose that yields a 50% lethal response
(LD50) or 50% cure (ED50) is often used
by the researcher as a preliminary statistic for
comparing the potency of different drugs.

Figure A shows example dose-response
data for a logistic regression analysis.

Figure A  Streptococci Data

Dose Response Count ln(dose)

The data are from an experiment where
rabbits were injected with different amounts
of penicillin to test the extent of protection
from potentially lethal injections of beta-

to create a column like ln(dose) in this
example.
Use these steps to do a dose-response
analysis and show the response curve:

• Be sure the response is either nominal or
ordinal (N or O). If the response is coded
numeric (0 or 1), use the popup menu at
the top of the column and change the
modeling type to N or O.

• Choose Analyze→Fit Y by X and select
Response as Y and ln(dose) as X. The
example data are summarized so Count
is the Freq variable. When you click
Done you see the ln(dose) response
curve in Figure B.

Figure B  ln(dose) by Response With
Crosshair
Response By ln(dose)

R
es

po
ns

e

0

0.25

0.5

0.75

1

-3 -2 -1 0 1 2

ln(dose)

Cured

Died

Inverse Prediction

– 0.9211

The analysis includes the supporting
statistical tables shown in Figure C. The
test of the ln(dose) parameter estimate
shows that increasing penicillin dose
significantly increased probability of survival.
Together with the significant whole model
chi-square test, the logistic curve appears to
be a good fit for the data.

Figure C  Logistic Regression for Response
by ln(dose)
Converged by Gradient

Whole-Model Test

Model
Difference
Full
Reduced

-LogLikelihood
 18.970251
 18.311413
 37.281664

DF
      1

ChiSquare
 37.9405

Prob>ChiSq

  <.0001

RSquare (U)
Observations (or Sum Wgts)

 0.5088
     54

Parameter Estimates

Term
Intercept
ln(dose)

Estimate
2.66177407
 2.8988935

Std Error
0.8162394
0.7629513

ChiSquare
 10.63
 14.44

Prob>ChiSq
0.0011
0.0001

To estimate the amount of penicillin needed
to cure at least half of the rabbits (the ED50),
use inverse prediction in either of the
following ways:
• Choose the crosshair tool from

the Tools menu and move along
the dose-response curve until it
intersects .5 on the response (Y) axis.
Read the approximate ED50 dose,
–0.9211, as shown in Figure B.

• Click the pop-up menu beneath the plot
and choose Inverse Prediction. Enter
one or more response rates into the
Inverse Prediction dialog and click Done.

The example in Figure D shows predicted
ln(dose) levels for response rates from .95 to
.05. From the Inverse Prediction table you can
see that a more accurate estimate of the
ED50 is –0.92286, or in original dose units,
e–0.92286 = .397381.

Note: Inverse prediction on the Fit Y by X

platform is only available if there are two
response levels. If you have more than two
levels or have covariates use the Fit Model

command.
Mantel, 1963, “Chi-Square Tests With One Degree

of Freedom: Extensions of the Mantel-Haenszel
Procedure,” Journal of the American Statistical
Association, 58:690-7000.

hemolytic streptococci. The response is
whether the rabbits were cured or died.

Note that the data table in Figure A is
summarized to show the frequency
(Count) for each combination of dose and
response.

Often the natural log of dose is the pre-
ferred response for a dose-response
analysis. You can use the JMP calculator

Figure D  Inverse Prediction
Inverse Prediction

Probability
      0.95
      0.75
       0.5

      0.25
      0.05

         •
         •
         •

1-Alpha
 0.9500

Click/Enter values for Probability

Done Help

      Dialog and Inverse Prediction Table

Enter probabilities and alpha levels. The Inverse Prediction table shows
inverse predictions with confidence limits for each combination of
probabilities and alpha levels.

Inverse Prediction
Probability
0.95000000
0.75000000
0.50000000
0.25000000
0.05000000

Predicted ln(dose)
 0.08912878
-0.54527462
-0.92286336
-1.30045209
-1.93485549

Lower Limit
-0.33613445
-0.83718753
-1.26101445
-1.88351446
-3.14484571

Upper Limit
 1.30716646
 0.04429014
-0.58175102
-1.00911909
-1.51171724

1-Alpha
0.9500
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STACKING MULTIPLE SETS OF
COLUMNS
by Ann Lehman
SAS Institute Inc.

Recently someone asked the question,
“What is the easiest way to stack multiple
sets of columns?”

For example, what is the simplest way to
change this arrangement:

5 Cols

3 Rows block A1 A2 B1 B2

into the following form?
block A B

1 A11 B11
1 A21 B21
2 A12 B12
2 A22 B22
3 A13 B13
3 A23 B23

This looks like a job for the Stack command
in the Cols menu, but Stack only facilitates
stacking into a single output column. This
example needs two output columns.

Next, use Analyze→Distribution of Y to
create a histogram of the _ID_ variable
produced by the Stack command. Highlight
histogram bars to define subsets of data.
You do this by highlighting the bars for
either the A variable or the B variable as in
Figure B. (Note: you can also use the
Group/Summary command to define
subsets.)

Now do two things to the stacked data
table:
• Use Tables→Subset to extract the

highlighted rows from the table.

• Click the stacked table to again make it
the active table, and use Rows→Delete

to delete the highlighted rows from it.

You now have the two tables shown in
Figure C.

The last step in this process is to do a simple
join by row number of the two subsets. To
do this, choose Tables→Join and complete
the Join dialog. Also, click the Select

Columns box on the Join dialog and keep
only the columns shown in Figure D.

For the sake of notational convenience,
change the column namees in the joined to
A and B in the respective subset tables as
shown.

Figure D  Join Subsets for Final Results

A6 Rows

3 Cols

block B

To summarize
The steps needed to stack multiple sets of
columns are:
1) Stack all columns into a single column.
2) Create a subset for each set of columns.
3) Join the subsets.

You can use these steps to stack as many
sets of columns as required by your data.

However, there is an easy way to take
advantage of several Tables menu and Cols

menu features in JMP and get the desired
result.

You begin by using Cols→Stack to pile all
four columns in the original example (A1, A2,
A3, and A4) into a single column, which gives
the table shown in Figure A.

Figure A  Table with One Stacked Column

_Stacked_ _ID_12 Rows

3 Cols

block

Figure B  Use Distribution of Y to Identify a Subset

Create two subsets:_Stacked_ _ID_12 Rows

3 Cols

block

_ID_

A1

A2

B1

B2
Highlight histogram 
bars to identify rows 
for a subset.

Delete the highlighted 
rows, leaving the 
original table as the 
second subset.

Create the subset of 
highlighted rows.

Figure C  Subsets from Stacked Table

_Stacked_ _ID_6 Rows

3 Cols

block _Stacked_ _ID_6 Rows

3 Cols

block
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Use The Attributes Table!

Figure A  Example of Data with Many Columns Characteristics

ID Q1 Q2 Q3 Q4 Q566  Rows

121 Cols

Q6 Q7

Figure B  Attributes Table Example to Change Modeling Type

to be Changed

Use the Attributes command
to change all responses from
continuous to nominal and
to assign Y Roles.

and Analysis Role
There are occasions when many or all the
columns in your JMP table need to have the
same change made to them. For example,
suppose you imported data that had many
columns with responses coded as 0 or 1.
Survey data with yes/no questions are
sometimes coded that way. By default, the
JMP import command constructs a numeric
data type for a column containing all
numbers, and assigns those columns the
continuous modeling type.

The table in Figure A shows 120 columns
called Q1, Q2, …, Q120 with continuous
numeric 0 or 1 responses. If you wanted a
count and a histogram for all Q variables,
their modeling type needs to be nominal.
Changing each of them through the Column
Info dialog would be unreasonably tedious

121 Rows

9 Cols

Name Type Measure FW N Dec Lock Source Validation Role

121 Rows

9 Cols

Name Type Measure FW N Dec Lock Source Validation Role

Name Type Measure FW N Dec Lock Source Validation121 Rows

9 Cols

2

3
4

66  Rows

121 Cols

ID Q1 Q2 Q3 Q4 Q5
Update Source

Sort Contents…
Add Col Notes
Max Col Notes Width…

and time consuming.

This is a situation where the Attributes

command in the Tables menu comes in
handy. The Attributes command creates a
new table called an attributes table from
the active data table, called the source
table. An attributes table has a row for each
column in its source table and a column for
each type of column characteristic. You can
quickly make global changes to table
columns by entering new values into its
attributes table:
• Name lists the variable names in the

source table. You can type in new column
names using up to 31 characters.

• The Type (data type) column has values
“Numeric,” “Character,” or “Row State.”

• Measure (modeling type) has values
“Continuous,” “Ordinal,” and “Nominal,”
which specify how JMP uses the column
for data analysis and plotting.

• FW lists the field width of each column.

• N Dec lists the number of decimal places
assigned to display numeric columns.

• Lock has values “Yes” or “No,” which tell
whether a source table column is locked
so it cannot be edited, or unlocked.

• Source has values “No Formula,”
“Formula,” or “Instrument” to indicate the
source of the input data.

• Validation has values “None,” “Range
Check,” or “List Check” to indicate
admissible values in a column.

• Role can have values “None,” “X,” “Y,”
“Weight,” “Freq,” or “Label.”

Figure B shows the sequence of actions you
do to change the modeling types from
“Continuous” to “Nominal”, and to assign “Y”
to all response columns:

1) Choose Tables→Attributes to see the top
table in Figure B.

2) Highlight “Nominal” in the Measure

column and choose Edit→Copy. Then

highlight the Measure column itself and
choose Edit→Paste to change all columns
to “Nominal,” as shown in the second table
of Figure B.

3) Enter a “Y” into a Role column cell. Then,
select the cell and choose Edit→Copy.
Highlight the Role column and all the rows
except the first, as shown in the third table
of Figure B. Choose Edit→Paste to
change all response columns to “Y”.

4) Select the Update Source option from
the dollar ($) popup menu on the window
border to make changes in the source
table, as shown at the bottom of Figure B.

The attributes table is useful for other
commonly encountered global changes such
as removing formulas, unlocking columns,
and changing data types; and is especially
useful to set the same number of decimals to
display on multiple columns.

          



8

JMP FOR USER PUBLISHING

SAS® User Publishing Program
SAS Institute Inc.

Have you considered writing about JMP?
Are you interested in publishing an article
or a book? Having difficulty imagining what
authoring would be like? SAS Institute’s
User Publishing Program can assist you!

The SAS User Publishing Program has two
branches, one for Books by Users (BBU),
the other for Observations®: The Technical
Journal for SAS Software Users. BBU handles
books written by SAS users for SAS users.
Observations publishes feature articles
submitted by SAS users and Institute experts.
Both branches are open to authors who want
to write about JMP.

The goal of User Publishing is to make the
process of writing and publishing as easy
for you as possible while ensuring a quality
publication. The User Publishing team
takes care of details so that you can
concentrate on writing. Here is how we can
help regarding your JMP publishing needs.
We offer:
• complete editorial and publishing

support
• technical advice and assistance
• access to an audience of JMP users
• competitive royalties for books
• honoraria for Observations articles.

The Author’s Packet provides detailed
information on how to prepare and submit
proposals for BBU and Observations.
Proposals include a completed Author’s
Questionnaire and an outline for a BBU
book or a full draft of your Observations
submission. Your outline or draft will be
reviewed by a team of technical experts.

The publishing agreement you sign with
the Institute specifies your rights and
responsibilities as author and the Institute’s
rights and responsibilities as publisher. Your
acquisitions editor from User Publishing
will then assist with development and
organization.

During technical review, copyedit and
production, your editor will work closely
with you to ensure a polished final product.
You won’t have to focus on grammar,
punctuation, usage, spelling or format.
Leave the worry to us and soon you’ll be a
published author!

To request an Author’s Packet or additional
information regarding BBU or
Observations send electronic mail to:

sasbbu@unx.sas.com or
sasobs@unx.sas.com

For more information on either option
access SAS Institute’s site on the World
Wide Web at the following URL:

http://www.sas.com/

You may call any of the following BBU
representatives at (919) 677-8000:

Irene Down x 6479
sasimd@unx.sas.com

Julie Platt x 7447
sasjmp@unx.sas.com

Judy Whatley x 7451
whatley@unx.sas.com

Betty Angell x 6179
sasbxa@unx.sas.com

Hanna Schhoenrock x 6422
sashxh@unx.sas.com

Or, send facsimiles to (919) 677-4444
attn: BBU

Mail correspondence to:
User Publishing Program
SAS Institute Inc.
SAS Campus Drive
Cary, NC 27513-2414

The User Publishing team will be watching
for your JMP submission. Contact us. We’ll
jump for you!

JMP SERVICES UPDATE
Professional Services Division
SAS Institute Inc.

SAS Institute currently offers the following
JMP courses:
• Interactive Data Analysis Using JMP

Software (2 days)
• Design and Analysis of Experiments

Using JMP Software (1 day)
• Engineering Statistics Using JMP

Software (2 days)
• Reliability Analysis Using JMP Software

(1 day).

SAS Institute is expanding its JMP
curriculum to include the following topics
(available in November 1996):

• Categorical Data Analysis Using JMP
Software

• ANOVA and Regression Methods
Using JMP Software

• Multivariate Statistical Methods Using
JMP Software

• Advanced Design and Analysis of
Experiments Using JMP Software.

You can attend selected JMP training
courses at an Institute training center or
schedule any of the courses at your site.

In addition to formal classroom training,
SAS Institute’s Professional Services
Division also offers JMP consulting services.
You can receive short-term on-site services
designed to help you efficiently and
effectively use JMP software to complete
your data analysis tasks. The Institute can
provide you with a full range of expert JMP
software services and professional
assistance tailored to your organization’s
immediate computing needs.

For more information on JMP training and
consulting services, contact Deborah
Upchurch at SAS Institute's headquarters in
Cary, NC at

919-677-8000,   x 7312.
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VARIABILITY AND GAGE
R&R ANALYSIS
by Liz Edwards and Dave Tilley
SAS Institute Inc.

JMP 3.1.5 introduces a new feature called
Variability Analysis. This kind of analysis is
useful for anyone involved in manufactur-
ing, quality control, or any analytical process
where frequent measurements are made
throughout the process. A manufacturing
or analysis process can only produce good
quality results if all people and equipment
are making consistent measurements.

Human error or damaged equipment can
cause poor measurements that contribute
to overall product variation. The Variability
Analysis platform provides graphical and
statistical tools, such as Gage R&R analysis
(Gage Repeatability and Reproducibility
Analysis), which can help you identify
trouble spots in your measurement system.

A measurement system includes the actual
instruments (sometimes called gages)
used to make a measurement, the people
making measurements (the operators),
and the parts (products) being measured.
To evaluate a measurement system, a
standard set of parts are measured several
times by each operator with the different
instruments. Once you have collected this

data, you can look for variations between
instruments, between parts, or between
any combination of instruments and parts.
In recent years, more quality analysts have
recognized the importance of assessing
gage capability. There is greater awareness
that the tools used to obtain quality
measurements are themselves subject to
variation. Overall product variation can be
broken down into two components:
variation due to the product and variation
due to the gage. That is:

σ2total = σ2product + σ2measurement

Gage R&R looks at measurement variation
and attempts to quantify the ability of the
measurement system to perform
adequately.

Repeatability is the ability of the gage to
give consistent results when the same
technician or operator takes several
measurements of the same unit.
Reproducibility is the ability of the gage to
give consistent results when different
operators use it to measure the same unit.

Note: The Variability Analysis platform in
JMP handles only random effects models
with complete and balanced data. That is,
there are an equal number of measure-
ments taken at each combination of factor
levels, and there are no missing values.

Graphical Methods
To improve a process, you must identify
the sources of measurement error and
examine the components of variation.
Figure A shows an example of the
arrangement of data for a 2-factor crossed
model. The table contains measurements
taken by 5 operators on 10 parts. The table,
called 2 Factors Crossed (Mac) or
2crossed.jmp (Windows) is in the JMP
sample data.

Figure A  Variability Analysis Data

To produce a Variability chart, you choose
Graph→Control Charts, which displays the
Control Charts dialog. You then click the
Variability Charts button to see the
Variability Charts dialog as shown at the
lower left of Figure B.

The default analysis is a 2-factor crossed
model, but other models are available in the
Model Type popup menu on the Variability
Charts dialog. Enter your response
measurements and factors for Operator
and Part, and click Chart to see a Variability
chart like the one shown in Figure C.

Figure B  The Variability Charts Dialogs Figure C  Variability Chart for 2-Factor Crossed Model
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Variability charts offer you a quick visual
assessment of several components of
variation all at once.
• The error-bar notation at each point

shows the range of measurements made
by each operator on each part, called
“repeatability” in Gage R&R terms. Small
ranges for each operator demonstrate the
operator’s ability to obtain consistent
measurements with the gage.

Figure D  Analysis of Variance and Variance Components Tables
Analysis of Variance

Source
Operator
part#
Operator*part#
Error

DF
   2
   9
  18
  60

SS
 0.05489
 2.63358
 0.37567
 0.24833

Mean Square
0.02744
0.29262
0.02087
0.00414

F Ratio
  1.3150
 14.0209
  5.0425

Prob>F
0.29306
0.00000
0.00000

Variance Component Estimates

Component
Operator
part#
Operator*part#
Error

Var Comp Est
0.00021914
0.03019444
0.00557716
0.00413889

% of Total
  0.55
 75.24
 13.90
 10.31

Cum. Total
0.0002
0.0304
0.0360
0.0401

Cum. %
   0.5
  75.8
  89.7

 100.0

Sqrt(VC)
0.0148
0.1738
0.0747
0.0643

• You also compare the plotted average of
each operator’s measurement on the
same part, or “reproducibility”. Close
measurements taken by different
operators on the same part are a sign of
small operator variability. However, you
expect the part-to-part measurements
taken by each operator to vary
substantially. This indicates the gage’s
ability to differentiate among parts.

Analysis of Variance and
Variance Components
The random effects model estimates
variances of effects or variance components.

The Variability Analysis platform also displays
the Analysis of Variance and Variance
Component Estimates tables for the model
type and factors selected (Figure D). The
“% of Total” column in the Variance
Components Estimates table is of particular
interest. It shows how the total variation is
partitioned among the effects in the model.
In this example, most of the variability is
attributable to part-to-part variability.

The Gage R&R Report: Variance
Components Method
For a 2-factor crossed design, the Variability
Analysis platform displays a Gage R&R

and the tolerance factor you specify in the
Variability Chart dialog.

Figure E is the Gage R&R Report
generated for this example of a 2-factor
crossed model. The Measurement Unit
Analysis lists these quantities:
EV Repeatability - equipment variation,

computed
υ σEV

2 .
AV Reproducibility - operator -to-operator

variation, computed
υ σAV

2 .
IV Interaction - interaction of operator and

part, computed
υ σ IV

2 .
RR Gage R&R - measure of repeatability

and reproducibility, computed
EV AV IV2+ 2+ 2

PV Part variation, computed
υ σPV

2 .
TV Total Variation, computed

RR2+PV2

In the Gage R&R report, % Tolerance lists
the Measurement Unit Analysis for EV, AV,
IV, RR, and PV divided by the tolerance you
specified in the Variability dialog.

Discrimination Ratio
The variability of the quality measurement
is composed of variance due to the product
itself and the variance of the measurement
error: You want the measurement process
be able to detect product variation. For each
factor, the discrimination ratio quantifies the
usefulness of the response measurement
for a product. (Wheeler and Lyday, 1989).

For a given factor, X, the discrimination ratio
compares the product measurement, Y, and
variance of the response measurement, Vx,
with the measurement error  variance, E.
The Discrimination Ratio, D, is computed

D = 2VX(
E

) – 1

Computational note:
The mean square for error E is taken from
the Variance Component Estimates table.

For a factor X with k levels, Vx, is
computed

var(mean Yk) +((Nk– 1)/Nk)•E

As a rule of thumb:
• A Discrimination Ratio less than 4

indicates the measurement error is so
great that it masks the product variation.
This means it would be best to work on
improving the measurement process

Report. JMP uses a statistically more efficient
version of the traditional approach to Gage
R&R. The calculations are done using
estimates of the variance components
instead of variance estimates based on
ranges; the method of moments approach is
used to solve for the variance components.
Computations use the sigma multiple (υ)

Figure E  Gage R&R and Discrimination Reports
Gage R&R
Measurement Unit Analysis
Repeatability (EV)
Reproducibility (AV)
Operator * Part Variation (IV)
Gage R&R (RR)
Part Variation (PV)
Total Variation (TV)
Sigma Multiple
Tolerance

 0.3313211
 0.0762367
 0.3846040
 0.5133283
 0.8948923
 1.0316676
 5.1500000
 0.4000000

% Tolerance
  82.830
  19.059
  96.151
 128.332
 223.723

Gage R&R Report assumes that column 'Operator' represents Operator,
and column 'part#' represents Part.

Discrimination Ratio
Source
Operator
part#

Discrim Ratio
 1.1727709
 4.0606574

Guidelines (Barrentine, 1991) for 
acceptable % RR are:
< 10%  excellent
11% - 20% adequate
21% - 30% marginally acceptable
> 30% unacceptable.
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because identifying product variation
will not even be possible until that is
accomplished.

• A Discrimination Ratio greater than 4
implies that it is possible to detect
unacceptable variation. (Wheeler and
Lyday 1989).

Generalization
The value of variability and Gage R&R
analysis is not confined to a particular
manufacturing process or industry. For
example, the ‘operator’ factor could be
thought of generically as any condition
affecting measurements such as a set-up
procedure, an environmental condition
such as temperature, or date. Likewise the
‘part’ factor could be any standard factor in a
process, such as work shift or weekday.

Variability Analysis in JMP accommodates
1 to 3 factors with interactions, which can
be crossed or nested, as well as crossed
and then nested.

The flexibility, scope, and ease of use of the
variability platform makes it a valuable
addition to the statistical and graphical
techniques for total quality improvement
that are available in version 3.1 of JMP.
ASQC Automotive Industry Action Group

(1990), Measurement Systems Analysis
Reference Manual, ASQC Automotive
Industry Action Group.

Barrentine (1991), Concepts for R&R Studies,
Milwaukee, WI: ASQC Quality Press.

LaBarr, Julie (1994), “SAS Tools for Assessing
Gage Repeatability and Reproducibility,“
Proceedings of the Nineteenth Annual SAS
Users Group International, Cary, NC, SAS
Institute Inc.

SAS Institute Inc., SAS/QC Software: Usage and
Reference, Version 6, First Edition, Volume 2,
Cary, NC: SAS Institute Inc., 1995. 1697 pp.

Wheeler, D.J. and Lyday, R.W. (1989),
Evaluating the Measurement Process.,
Second Edition, Knoxville, TN, SPC Press Inc.

Want to communicate with other JMPers? Join
the JMP-L discussion list. Send email to
    majordomo@wubios.wustl.edu
with the one line message
    subscribe JMP-L

VISUALIZING A
3-D FITTED
SURFACE
by Michael Hecht
SAS Institute Inc.

JMP’s Fit Model platform can produce a
wide variety of fits to your data, but some of
them are difficult to visualize using JMP’s
default graphics. In particular, if your data is
best fit by a three-dimensional surface,
such as a response surface, you must do
some extra work to see the fit and the data
in the same graph.

I started with the data in Figure A: 20
observations of data, variables X, Y, and
response variable Z. To identify these
original data values, I added the character
column named source to the data table,
and used a formula to set its value to the
constant character  string “data”.

Figure A  Example Data for 3-D Fitting

sourceX Y Z

I wanted to visualize a surface fit to this data
in a spinning plot that would show both the
original data values and the fitted surface.
To begin, I used the Fit Model platform,
and produced a fit of Z from a response
surface of X and Y.

To get the fitted surface itself, I knew I
would have to calculate its points. So, I used
the Save Prediction Formula option found
in the Save ($) menu of the Fitting
Platform. This created the Pred Formula Z

column in the data table as shown in

Figure B, and attached the formula that
describes the fit.

Figure B  Surface Fit with Predicted Values
+++1.23727277 •-0.0122591 X •0.00469837 Y

+ •X •X -0.1136486 + •Y •X 0.0083235 + •Y •Y -0.1197364

surface fit prediction formula �

sourceY Z Pred Formula Z

So far, so good. I decided it would be easier
to generate the surface points in a separate
table. So, I used COMMAND-click (Mac) or
ALT-click (Windows) to  select (highlight)
the  X, Y, source, and Pred Formula Z

columns. I omitted Z. Then I used
Tables→Subset to produce a new data
table that contained only those four
columns, and renamed Pred Formula Z to
simply  Z, so it would match the original
table. Also, I changed the character  string
in the  source formula  to have the value
“fit” instead of  “data.” The subset table
looks like this:

Figure C  Subset to Generate Surface Value

sourceX Y Z

Next, I added formulas for X and Y so they
would count in a simple rectangular fashion.
I used nested count formulas, as described
in Chapter 5, Calculator Functions, of
The JMP User’s Guide.

The formula for X is
from -3, to 4, in n  steps, n  timescount( )

and Y’s formula is
from -3, to 4, in n  steps, 1 timecount( )

I picked the start and stop numbers –3 and
4 by using Analyze→Distribution of Y for
both  X and  Y, and choosing the values on
the extreme ends of their histograms.

Now I could generate a surface by adding
rows to the table.

����
Continued
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I wanted the number of rows to be a
perfect square, so I chose 22x22 = 484
and added enough rows (464) to reach
this amount. The number of rows to add
is arbitrary, but determines the density of
the surface.

The only remaining task was to glue this
table to the original  table. I went back to
the original table and deleted the Pred

Formula Z column, as it was no longer
needed. I then used
Tables→Concatenate and it produced
the final table you see in Figure D.

Figure D  Combined Data and Fit Table

sourceX Y Z

At this point, the prize was easily within my
grasp! I created a spinning plot of X, Y, and  Z.
A Distribution of Y histogram of the  source

variable was useful to select and color or mark
the two kinds of points (“data” and  “fit”). The
result  (Figure E) was quite impressive (even
breathtaking when viewed in color).

 Figure E   The Prize Spinning Plot
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